Version error

(4 posts) (2 voices)


No tags yet.

  1. fastscot, Member

    I downloaded v1.2.2 this morning and installed the database updates and the new application. I was unable to login. After getting the Welcome to myDBR screen and entering the connection details, I get an error saying that the Database version does not match the application. The welcome screen shows the application as 1.2.2 but when I go into the database it shows as 1.2.0. I believe there are 2 bugs in the mysql database install script (mydbr_create_mysql.sql). Line 135 of the script shows an insert into myDBR_version of 1.2.0. Also on line 241 there appears to be an additional delimiter with no command in front of it which causes the script to fail (I removed it to get it to run). I tried manually changing the version in the database table myDBR_version to 1.2.2 but I still get the same error.

  2. myDBR Team, Key Master

    Let's try to figure out what the problem is.

    The version number 1.2.0 in mydbr_version is intentional, since it has a reference to the last major version number. The mydbr_version-table itself is new and will be used in the upcoming versions to see what tables needs to be updated.

    There is indeed an extra delimiter in the script, but it should not cause any problems. What method are you using to run the script and what version of MySQL are you using?

    In order to check if the database is updated in myDBR 1.2, myDBR for now simply checks if new 1.2 tables are there. The check is done now from information_schema.tables and it is looking for the new mydbr_version-table. If myDBR does not find that this new table is created, myDBR assumes that the database version is still the old one and prints out the warning.

    Could you check that the mydbr_version-table exists and your admin_username you are using has privileges to read the information_schema.tables. In future releases we are going to use the newly created mydbr_version-table to check the installed version.

    Let us know if this helps.

    myDBR Team

  3. fastscot, Member

    I did get everything working. I had to re-install the license. I also changed the version back to 1.2.0 in the database. The database had been changed correctly (new tables) and I simply opened the script in the mysql query browser (File | open script) and then executed the query.

  4. fastscot, Member

    PS. I'm using mysql version 5.0.51


You must log in to post.