Chrome SQL editor selection issue

(9 posts) (3 voices)
  1. nsepetys, Member

    Hello myDBR Representative,

    How is it going? I am having an issue with the SQL Editor in my Chrome Browser (version 39.0.2171.99). If you can see the image here you'll notice there is overlapping going on with the text selecting (highlighting):

    While it doesn't prevent me from selecting text it does make it difficult to edit a long stored procedure. I have disabled my ad blocking plugin just in case that was it. I also tried checking for new versions of Chrome and I think I have the latest. In addition to all that I have also cleared my cache/browsing history but none of these things seem to do the trick to fix the issue.

    I am currently using myDBR version 4.3.3 and I just started noticing sometime soon after that update. Internet Explorer and Firefox both work fine for now but it'd be nice to not have to switch browsers for the best myDBR experience.


  2. myDBR Team, Key Master

    we do not seem to be able to reproduce it with latest Chrome (40.0.2214.93). What is the OS/version you are running the Chrome in?

    Note that you might sometimes get this issue if you have a report with very long rows / in some cases if you resize the browser window. By resizing the window / turning off word wrap usually helps.

    myDBR Team

  3. nsepetys, Member

    I am running Windows 7 SP 1. I do have long rows but this doesn't seem to affect other browsers. Are you saying that you cannot replicate even when testing procedures/queries with long rows? I have tried switching to unwrapped word wrapping and resizing the browser window but this problem still persists. You have any other suggestions?

  4. myDBR Team, Key Master

    We tried to create a issue with Windows 7 SP 1 + Chrome version 39.0.2171.99 m and newest 40.0.2214.93 m, but where unable to create it. This does not mean that it could not happen as we've seen the issue in past (we've fixed many of the causes for this from the underlying editor component). If you have the issue, resizing the editor window, toggling the word wrapping mode or using shorter lines should help.

    Do you get the issue every time you open a report? Based on the image you seem to have the issue when opening the demo's "All Continents"-report. Do you get the problem if you have the windows wide enough for the lines and open the report code?

    myDBR Team

  5. nsepetys, Member

    It's interesting that you cannot replicate on your end. I get some variation of the issue for every report that I open in the SQL editor. Sometimes it's more noticeable like in the screenshot above and other times there is a small amount of shadow selecting going on where the highlighted text is shifted from the original text by a small margin.

    It doesn't matter the size of the browser's window, whether the word wrapping is enabled/disabled, or the length of the lines (although the length of the lines does impact the severity with the longest lines causing that worst of the unsightliness). The only thing I haven't done is uninstall and reinstall the browser. I will have to try that I suppose since it cannot be replicated.

  6. nsepetys, Member

    Just an update- the reinstall did not do the trick. I now have Chrome version 40.0.2214.94 m and the issue still persists. I also had my coworker verify on his station and he managed to replicate the issue. He is using Chrome version 39.0.2171.95 m and Windows 7 SP 1. Do you have any ideas on how we could potentially determine the issue if it is indeed local?

  7. myDBR Team, Key Master

    If your server is accessible to us, we could take a look what is causing this.

    Otherwise, could you send couple of full resolution screenshots of the editor showing highlighted text is shifting to support email. We can see if if spot something that is different.

    myDBR Team

  8. Ken, Member

    I created an issue about this happening with Firefox 35.0.1.

    You can close the new issue I posted since this is the same problem I'm having.

  9. nsepetys, Member

    The highlighting issue has been fixed.It appears that the issue had something to do with some temp files I had for my Chrome browser. If you also have the issue I suggest you wipe all temporary files for your browser. Thanks all!


You must log in to post.