Proxy not working on network

(5 posts) (2 voices)


  1. tardis89, Member

    When I change the proxy to the correct settings for my network under Enviromental Settings, I am unable to update. Is there anywhere else to edit the proxy settings so I don't have to manually update? Each time I manually update, I have to change a bunch of custom settings again.

  2. myDBR Team, Key Master

    Have you checked your proxy log if there is something there? The proxy setting should work, but some proxy servers might require specific settings (authentication etc).

    You can add additional proxy parameters via $mydbr_defaults['proxy'] array which will be parameters to curl_setopt. For example to set CURLOPT_FOLLOWLOCATION you add:

    $mydbr_defaults['proxy'][CURLOPT_FOLLOWLOCATION] = 1;

    myDBR Team

  3. tardis89, Member

    My proxy settings do not require authentication. It should be fine with just the host and port (eg. I have proxy working correctly on

    Where are the proxy logs located for mydbr?

    And what file would I do that $mydbr_defaults command in to change the update options?

  4. myDBR Team, Key Master

    do you have php_curl installed in your PHP?

    $mydbr_defaults is defined in mydbr/defaults.php. To change the settings, override the defaults in mydbr/user/defaults.php. When doing the updates, the mydbr/user/defaults.php is preserved.

    myDBR Team

  5. tardis89, Member

    Thank you!

    php_curl was the issue.

    As soon as I enabled php_curl in my php.ini file, the update feature worked.


You must log in to post.