MyDBR with HHVM

(4 posts) (2 voices)
  • Started 3 years ago by drraab
  • Latest reply from myDBR Team
  1. drraab, Member

    Hello,

    I am running a webserver with HHVM (used by e.g. MediaWiki).

    After installing MyDBR I can not for the life of me get it to work. I tried adding a location specific for MyDBR and run it through PHP-FPM instead of HHVM (as HHVM and Ioncube are non-compatible).

    I've downloaded and ioncube modules and added them to /etc/php.ini but I am never able to get passed the initial installation step where MyDBR just continues to tell me to install ioncube - which is installed and OK.

    From MyDBR:
    Copy loader to extension directory ToDo

    From the ionCube installation package copy the file ioncube_loader_lin_5.6.so to directory /usr/lib64/hhvm/extensions/
    Add loader to php.ini ToDo

    Add the following line to <php.ini>
    zend_extension = /usr/lib64/hhvm/extensions/ioncube_loader_lin_5.6.so

    I do NOT have PHP 5.6, I am running 5.4 and using that information causes:
    # php -v
    Failed loading /usr/lib64/hhvm/extensions/ioncube_loader_lin_5.6.so: /usr/lib64/hhvm/extensions/ioncube_loader_lin_5.6.so: undefined symbol: zend_execute_ex

    So I changed it to _5.4.so and this tells me:
    # php -v
    PHP 5.4.16 (cli) (built: Jun 23 2015 21:17:27)
    Copyright (c) 1997-2013 The PHP Group
    Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v5.1.1, Copyright (c) 2002-2016, by ionCube Ltd.

    Looks good right?

    I've tried a bunch of different nginx settings but I cannot get it working as MyDBR keeps telling me to fix Ioncube and my PHP states its all good.

    location /mydbr {
    # root /usr/share/nginx/html/mydbr;
    include fastcgi_params;
    fastcgi_index index.php;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    # fastcgi_param SCRIPT_FILENAME /usr/share/nginx/html/mydbr/$fastcgi_script_name;
    # fastcgi_param SCRIPT_FILENAME $document_root/mydbr/index.php;
    fastcgi_param SERVER_NAME $host;
    fastcgi_pass 127.0.0.1:9000;
    }

    My PHP-FPM port is 9000 and HHVM is 8000.

    Am I doing something wrong with my Nginx config here?
    Does anybody have a working example?

    Thanks!

    Posted 3 years ago #
  2. myDBR Team, Key Master

    Hi,
    what is the output of phpinfo() from myDBR directory? Do you see ionCube there?

    You might also want to try out ionCube loader wizard.
    --
    myDBR Team

    Posted 3 years ago #
  3. drraab, Member

    Hello,

    Thanks for your swift reply.

    Yes, I do see ionCube there (same information as shown by php -v above) and I have tried the ionCube loader wizard. I even tried the unofficial remi repo for CentOS to install it with yum as a desperate attempt.

    I think my Nginx configuration for this scenario must be wrong.

    Can you please provide a working example to set the /usr/share/nginx/html/mydbr folder as a seperate location in Nginx config and have it run with PHP, working redirects and whatnot MyDBR requires?

    Thanks alot myDBR Team!

    Posted 3 years ago #
  4. myDBR Team, Key Master

    Hi,
    if the ionCube is listed in the phpinfo() and you still have myDBR redirecting to the loader install screen, please check the following:

    1) Make sure you have the correct thread safety version of the ionCube. We've seen cases where this has not been the case and ionCube loader shows up in phpinfo() but does not function properly.
    2) Make sure you run the phpinfo() from myDBR directory.
    3) Make sure ionCube is loading also from a myDBR subdirectory. (Try to access mydbr/lib/commands.php. If you get an empty result that would be ok).

    --
    myDBR Team

    Posted 3 years ago #

Reply

You must log in to post.