Something Preventing Page From Fully Loading After Login

(12 posts) (2 voices)
  1. myDBR Team, Key Master

    You might want to check the apache error logs for any errors. Could be that some of the permissions are incorrect thus preventing access to some of the files.

    myDBR Team

  2. davidsona, Blocked

    Checked the apache error logs, and everything was ok. Also, checked permissions of folders/files inside my www directory and all are set so that anyone can read/write/execute against them. Any other ideas? Maybe something with SQL Server? Previously, I installed myDBR alonside mySQL instead of SQL Server (not realizing it had to be installed on the same platform as you'd be reporting off of... this was on another server), and I did not have this problem. Thanks :-\

  3. davidsona, Blocked

    Also, I should mention that it takes FOREVER for the initial login page to come up after i hit go on http://localhost/, and then it takes forever after I hit submit on login for it to pull up the partial page described above. So, something's not right there too - it shouldn't be anywhere near this slow. I'm not sure if that would be DB related also, or if maybe the ioncube decoder isn't working properly? (though the install wizard said it checked out ok after i installed it). Anyhoo, just thought I'd add this extra detail in case it helps. Also, for what it's worth, i've confirmed that you can connect to the db from another server using the sa credentials supplied to myDBR.

  4. davidsona, Blocked

    Ok, so, I feel kind of dumb now, but I tried deleting my cookies and temporary internet files, and now it works. However, it is still very slow. I'm watching my cpu while pages are waiting to load and it doesn't seem to be doing anything, so I'm not sure where the bottleneck is. The server is a VM 2.8GZ 4GB memory, running windows server 2003 and a basically idle sql server database, so the site should have plenty of resources. It would be MUCH more usable if it wasn't so slow... any ideas?

  5. myDBR Team, Key Master

    You need to isolate the thing that is causing the slow access. Sounds like your access path to database is the likely candidate.

    Try to access files in tools/troubleshoot-directory to see if your if it is your web server / php or the database access that is causing the problem.

    myDBR Team

  6. davidsona, Blocked

    Gotcha... This was helpful, got one step closer anyways...

    Tools/troubleshoot/extensions.php checked out ok:
    ionCube Loader OK
    MySQL Support OK
    Microsoft SQL Server / Sybase ASE / SQL Anywhere support OK
    ChartDirector support not installed

    However, Tools/troubleshoot/mssql.php revealed some problems:
    Warning: mssql_connect() [function.mssql-connect]: message: Login failed for user 'sa'. (severity 14) in C:\wamp\www\tools\troubleshoot\mssql.php on line 24

    Warning: mssql_connect() [function.mssql-connect]: General SQL Server error: Check messages from the SQL Server (severity 14) in C:\wamp\www\tools\troubleshoot\mssql.php on line 24

    Warning: mssql_connect() [function.mssql-connect]: Unable to connect to server: localhost in C:\wamp\www\tools\troubleshoot\mssql.php on line 24
    Unable to connect to the database. Login failed for user 'sa'

    I tried to SQL Server Management Studio using 'localhost' and login 'sa', and found that I could not connect b/c of an issue with the IP That SQL Server was listening on (it had the old DHCP IP from before I assigned the server a static IP). I corrected this, and restarted SQL services and WAMP services. At that point, I could connect fine via SSMS using SA, but I still couldn't connect via myDBR. So I thought maybe I should try reinstalling myDBR. Wiped the www folder and deleted the myDBR DB within SQL Server, and reinstalled. mssql.php reported the same errors, but myDBR app via http://localhost) was now reporting a new error message: "Unable to connect to database
    Login failed for user 'sa' because the account is currently locked out. The system administrator can unlock it." So then I thought, well maybe the app is expecting windows auth instead of SQL auth, so i reinstalled using a windows account and password for the DB config section. Still same thing. Then I reinstalled using 'CRS1' (name of this server) instead of 'localhost' (and modified freedts.conf to match), same thing. I'm not really sure what else to try at this point, but I'm oh so close. ?

  7. davidsona, Blocked

    PS - Can we do a WebEx session to fix this? I have a feeling that it's a simple configuration issue but I think if would help if you could see my screen and follow along directly with me... We will definitely buy myDBR if we can just get it installed and working :) From what I've seen, it's our best option for an affordable, but full-feature web-based reporting system w/ low overhead.

  8. davidsona, Blocked

    One more thing that I should have included in my 2nd to last post:

    The last time I tried reinstalling myDBR, I used these options for the DB:
    DB Type: Microsoft SQL Server (my DB is SQL Server 2008)
    DB Host: CRS1
    DB Login: dbr_admin
    DB Password: xxxxxx

    Install ran ok... myDBR web access still broken...

    Oddly, when i run tools/troubleshoot/mssql.php, it is still referencing a DB Host of 'localhost' and a DB Login of 'sa'. ?
    "Warning: mssql_connect() [function.mssql-connect]: Unable to connect to server: localhost in C:\wamp\www\tools\troubleshoot\mssql.php on line 24
    Unable to connect to the database. Login failed for user 'sa'." Why is it still referencing sa when it should be referencing dbr_admin?

    I know myDBR/dbr_admin can connect to the DB, though, b/c I added dbr_admin to all relevant DB roles (db_datareader, db_datawriter, db_ddladmin, etc) and it was able to create the myDBR objects (tables, SPs, etc) just fine. So... why can it access the DB at install but not when i'm trying to actually use the myDBR app??

  9. myDBR Team, Key Master

    First with the slow connection. Open the mydbr_config.php file and see if you have the port defined in the configuration (some configurations require the port to be defined, some do not). If you have, replace it with an empty string like this:

    define( "DB_PORT", '' );

    See that your freetds.conf contain following definitions:

    [global] host = localhost port = 1433 client charset = UTF-8 tds version = 8.0 text size = 64512

    As with the usage of 'sa' in troubleshoot/mssql.php, the file is totally independent from myDBR for the purpose of debugging the connection. If you open the file, you will see the definitions inside.

    myDBR Team

  10. davidsona, Blocked

    THANK YOU! Those edits fixed everything!!! :)

    For the benefit of anyone else that may have this same issue down the line, here's a complete rundown of the setup process that worked for me:

    myDBR Install / Database Setup
    1) First I created a new database named DB_MYDBR within my SQL Server instance on the WAMP server.
    2) Then I added dbr_admin as a SQL Server login, and mapped it as a user of DB_MYDBR.
    3) Then I edited the permissions of user 'dbr_admin' within DB_MYDBR, adding it to appropriate DB roles (dd_datawriter, dd_datareader, dd_ddladmin, etc).
    4) Then I was ready to install myDBR (I had already taken care of ionCube, etc prereqs). Here are the values that i passed into the DB portion of setup:
    DB Type: SQL Server
    DB Host: CRS1
    DB Port: 1433
    DB Name: DB_MYDBR
    DB Login: dbr_admin
    DB Password: xxxxxx

    Setup completed Ok, but app was left in the half-working state that I was battling throughout the latter part of this forum thread. To get it working, I made these edits recommended by myDBR team:

    Changed this line "define( "DB_PORT", 1433 );"
    To read like this "define( "DB_PORT", '' );"

    Replaced everything inside it with this:
    host = localhost
    port = 1433
    client charset = UTF-8
    tds version = 8.0
    text size = 64512" my case, everything except for "text size" was already set to these values... text size was set to a significantly higher value, though i don't remember exactly what.

    After I made those edits, myDBR instantly started to work. Pages load fast and more importantly, COMPLETE! It seemed counter-intuitive to have differing connection string values in the freeds.conf and mydbr_config.php files, maybe it was simply the "text size" value and not the connection string details. I don't know, but whatever it was, these edits fixed it.

    Thank you again myDBR Team! I really appreciate your help :)

  11. davidsona, Blocked

    PS - myDBR Team, you mentioned that I should be able to open the troubleshoot/mssql.php file to view method definitions... when I opened it, it was encrypted... Is there a way to use ionCube in an IDE to decrypt these files for viewing?

  12. myDBR Team, Key Master

    Glad you got it working. Few notes on the setup:

    1) The text size can be as big as you wish (Up to 4294967295). It simply sets the maximum width of any returned column. You are not likely to bump into this in myDBR if you do not use *very* large text fields.
    2) No need to set specific roles for mydbr user. Easiest way to do it is to define mydbr-user in SQL Server and set mydbr database owner to mydbr.
    3) Your problem was most likely caused by the port definition.

    Make sure you have the latest version installed (2.8 as of this writing). The tools/troubleshoot files are plain PHP files that you can freely edit.

    myDBR Team


You must log in to post.