HTTP Authentication not working after enabling Google SSO

(3 posts) (2 voices)

Tags:

No tags yet.

  1. maron, Member

    I have just enabled Google SSO on one of our dbr installations.

    I have a few external services calling it and authenticating using X-MYDBR-AUTH

    However, after enabling Google SSO the content the services are getting back is the following html

    <!DOCTYPE html><html><link rel="stylesheet" href="interface/style.css" type="text/css"><link rel="stylesheet" href="interface/normal.css" type="text/css"><body style="text-align:center"><div class="error">Unfortunately, we could not complete your request. Please contact your system admin.</div>OK</body></html>

    Is there a way of allowing local=true parameter when doing the authentication against report.php - or is there any other way to let our web service users still use the local db (not google authentication).

    We do have local logins enabled in defaults.php

    $mydbr_defaults['single_sign_on']['google']['show_local_login'] = true;

    Best regards,

    Maron

    Posted 2 months ago #
  2. myDBR Team, Key Master

    Maron,
    the HTTP Authentication will work with Google SSO enabled. They are separate from each other.

    What you are seeing is a generic error message shown to user who is not admin. Try adding following to user/defaults.php to see more verbose error message:

    $mydbr_defaults['server_error']['show_full_error_message_to_non_admin'] = true;

    --
    myDBR Team

    Posted 2 months ago #
  3. maron, Member

    Thanks - the security hash changed when enabling the google login.

    All fixed now.

    Posted 2 months ago #

Reply

You must log in to post.