Anon PDF generation with wkhtmltopdf

(5 posts) (2 voices)
  1. duane, Member

    Hi again,

    I have a report that generates a PDF perfectly when logged in and uses wkhtmltopdf. The report is set to "Access without login allowed via direct URL" - but when anon users click the link (in an email) the following error comes up:

    Does not seem to be a wkhtmltopdf export - $_GET["export"]: pdf - wkhtmltopdf skip_version_check is not active - SESSION wkhtmltopdf_exists. Value no

    Is this a config error with the myDBR or a web server or php issue? Any suggestions for solving it? (it might also be what is preventing me from attaching the pdf to the email)

  2. myDBR Team, Key Master

    Looks like that the check for wkhtmltopdf existence fails. myDBR checks that wkhtmltopdf exists in the system before it tries to use it.

    You can try a public report from

    Wass thre something special with the access/server?

    myDBR Team

  3. duane, Member

    OK - just realised the mydbr install now says wkhtmltopdf isn't installed despite is being installed (and changing nothing) for many months. I'll try and reinstall it.

  4. duane, Member

    Not sure what happened. But I have some strict settings for php_admin_value[disable_functions] for this server which once I temporarily commented out, restarted the webserver, cleared the cache and tried it - it worked fine again. I also tried to update the mydbr install and that was blocked until I did the same thing. perhaps too strict settings for php_admin_value[disable_functions] ?

    (but I have another subdomain on the same server and everything worked fine there - only difference was a different php config file.)

  5. myDBR Team, Key Master

    The wkhtmltopdf is a command line tool which myDBR calls. If you block the access (disabling exec/passthru) to it, the export functionality is not available.

    myDBR Team


You must log in to post.