dbr.upload - "you dont have permissions" for uploading

(5 posts) (2 voices)


  1. eugfri, Member


    i have created simple stored proc to try to test file upload functionality:

    CREATE DEFINER=`root`@`localhost` PROCEDURE `sp_DBR_Test`() BEGIN

    select 'dbr.upload.options', 'noreplace', 1; select 'dbr.upload.options', 'accepted_files', '.pdf';

    select 'dbr.upload', 'C:\\xampp\\htdocs\\mydbr\\ssn', 'sp_DBR_Test1', 123;

    select 'dummy';


    CREATE DEFINER=`root`@`localhost` PROCEDURE `sp_DBR_Test1`(in_path varchar(255), in_file varchar(255), in_size int, in_id int, inLogin varchar(128)) BEGIN

    select concat('File ', in_file, ' uploaded (',format_bytes(in_size),')');


    but when i try to run sp_DBR_Test I get the following msg just on trying to open it:

    "You do not have permissions for uploading. Please contact administrator."

    I run mydbr in XAMPP on windows, i.e. i use Apache, not IIS.

    What am I missing?

    Thank you

  2. myDBR Team, Key Master

    did you add the sp_DBR_Test1 as a report and add permissions to it?

    myDBR Team

  3. eugfri, Member

    yes, i have set it as report and set perms. But i m trying it as system admin anyways, so i suppose specific user groups perms should not matter. Anyways, still seeing the same error.

  4. myDBR Team, Key Master

    Double check that the sp_DBR_Test1 routine, jot just the sp_DBR_Test is added as a report and have correct permissions. The error comes after myDBR checks that you have permission to run the sp_DBR_Test1 routine. The code otherwise is ok.

    myDBR Team

  5. eugfri, Member

    oh, now i have added perms on sp_DBR_Test1 and everything works.

    Thanks a lot!


You must log in to post.