Query Editor does not show procedure in Chrome on OS X

(5 posts) (2 voices)
  • Started 6 years ago by shhedrick
  • Latest reply from shhedrick

Tags:

No tags yet.

  1. shhedrick, Member

    If I click on "Report Code" I get the window but the textarea for the procedure is blank.

    I have OS X 10.7.2 and Chrome 16.0.912.77.

    When I switch to IE9 under Win7 with Parallels, it works fine.

    MyDBR 3.3.0 build 1370.

    Thanks.

    Posted 6 years ago #
  2. myDBR Team, Key Master

    Chrome should work just fine. If other browsers work, your setup is OK. Try emptying the Chrome's cache.

    --
    myDBR Team

    Posted 6 years ago #
  3. shhedrick, Member

    Not sure what is going on. I cleared the cache with the same results. The buttons on the page also do not work. They look OK but clicking them does nothing. Its as if that page, and that page only, has no connection to the database. Clicking the report name link to run the report works and I can run the report just fine but if I click the "Edit Report Code" icon in the upper right, it takes me back to the non-working editor page.

    I tried the parameter queries page. all the queries are listed. I chose to edit one of them and clicked SQL Editor. same result.

    Do I have some odd option set incorrectly.

    This has worked for me before but os x and mydbr have both changed in the meantime so I can't isolate any particular change to the environment.

    Thanks.

    Posted 6 years ago #
  4. myDBR Team, Key Master

    We took a closer look at this one.

    Looks like Chrome is unable to display the Query Editor if the javascript code is not compressed. This seems to be a Chrome bug. To enable compression, make sure the directory mydbr/lib/external/editarea/edit_area is writable to the web server and then remove the edit_area_full_with_plugins.gz-file. This will trigger myDBR to recreate the compressed file and forces Chrome to fully reload it.

    You can open the mydbr/lib/external/editarea/edit_area/edit_area_compressor.php?plugins in your browser to see if the file is compressed or not (the non-compressed looks like normal js source code with line breaks).

    --
    myDBR Team

    Posted 6 years ago #
  5. shhedrick, Member

    That did the trick.

    Thanks!

    Posted 6 years ago #

Reply

You must log in to post.