myDBR 3.6 - "Dynamic Duo"

(4 posts) (2 voices)

Tags:

No tags yet.

  1. myDBR Team, Key Master

    myDBR Team is happy to announce the the availability of myDBR 3.6 release.

    myDBR 3.6 brings dynamic content handling of linked reports alongside various other improvements and fixes. Is is a recommended update for all users.

    New features/improvements:

    • Report default format can now be defined
    • Dynamic popups/embedded objects in linked reports based on ID's
    • Ability to open linked reports to new window
    • Autocomplete parameters can include ID's
    • Improved exports
    • Date and time scaling in charts
    • Time summaries above range of database time datatype scale
    • Charts embedded into HTML in export
    • Sticky header improvements
    • Multiple improvements to exports
    • 2nd yAxis title support
    • Public reports can now be constructed with name / hash in addition to report ID
    • Added dbr.mail.debug command for troubleshooting mail problems
    • ChartDirector 5.1 support

    Fixes:

    • Improved handling of null dates and times in editable
    • Fixed menu positioning inside relative object
    • Fixed Internet Explorer problems with SQL Editor
    • Fixed extra shadow problem with Firefox SQL Editor
    • skip_single_line_summary fixes
    • Fixes in crosstab behavior
    • More consistent popup close
    • Sybase Anywhere datatype fixes

    As always, you can update to new version using the myDBR's automatic updater.

    Happy reporting,
    --
    myDBR Team

    Posted 6 years ago #
  2. duane, Member

    FYI: after upgrading yesterday (build 1560), it resulted in an error as the table mydbr_reports was missing the new field 'export' (varchar 10 null). Once I added this manually the problem went away.

    Posted 6 years ago #
  3. myDBR Team, Key Master

    Did you do manual update or use the automatic update or notice anything unusual during the update? The automatic update will check the database and should make the necessary changes.

    To make sure you have all changes applied, you should run the database install script (Environment settings -> Report Database Setup -> re-run installation).

    --
    myDBR Team

    Posted 6 years ago #
  4. duane, Member

    I just used the automatic update but didn't notice anything unusual during the update - only after. This 'missing new fields' issue has happened once before and I was able to resolve it manually - but never identified the original 'problem'. Perhaps it is something to do with my setup - but I think it is pretty standard.

    I do have a custom user for mydbr access (using mysql) so perhaps that is it. It has all privileges for all actions for the mydbr database, but no server privileges nor for other tables like 'mysql' system table - perhaps it should?

    Posted 6 years ago #

Reply

You must log in to post.